EF2800i runs no AC power green AC pilot light on

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

EF2800i runs no AC power green AC pilot light on

jcy110
I run my EF2800i from time to time. Mine runs on natural gas and starts second pull every time.  The other night the power went off after a heavy rain so I got the generator out to power the sump pump and refrigerator. Started up right away, I plugged in the sump pump using an extension cord and the controller for the sump pump did not light up so I plugged in a clamp light.....nothing. The light on the GFI was amber so I checked the test/reset buttons and the reset would not click back in. The green AC pilot light is on but there isnt any power to the duplex GFI outlet or the twistlock outlet. I removed the cover so I could access both outlets from the back with meter leads. I only have 25.5 hrs on it and purchased it on 10-12-2013 after the hurricane sandy debacle of not being to get gasoline so I have the tri-fuel modification for gasoline, propane or natural gas. I drained and dried the tank the day I got it and never used anything but natural gas to run it.

I read about the magnets needing to be re energized after after not pulling a load.....does anyone have any idea on what to possibly what to check?  I even hooked in another GFI outlet and still no AC power.  Very frustrating to say the least because it worked other times, never acted up and has so few hours...

I have a 3000w PSW inverter that I can power from my 145AMP alternator in my Tahoe as a backup and I am glad I have it for instances like this.
Reply | Threaded
Open this post in threaded view
|

Re: EF2800i runs no AC power green AC pilot light on

jcy110
It was the GFI, I had to push the button in really hard to get it to reset on the NEW GFI.  Problem solved!